Commit 30720ea5 authored by incardon's avatar incardon

Fixing installation of MPI

parent 6d5a0c68
Pipeline #2013 passed with stages
in 19 minutes and 20 seconds
......@@ -24,7 +24,7 @@ echo "GPU compilation: $with_gpu"
if [ x"$hostname" == x"cifarm-centos-node.mpi-cbg.de" ]; then
echo "CentOS node"
./install_MPI_mpich.sh $HOME/openfpm_dependencies/openfpm_pdata/$branch/ 4
echo 4 > $HOME/openfpm_dependencies/openfpm_pdata/$branch/MPI/version
echo 5 > $HOME/openfpm_dependencies/openfpm_pdata/$branch/MPI/version
fi
if [ x"$hostname" == x"cifarm-ubuntu-node.mpi-cbg.de" ]; then
......
......@@ -113,7 +113,6 @@ fi
remove_old $i_dir $configure_options
exit 1
## Check and try to install the prerequisites
......
......@@ -169,14 +169,11 @@ function remove_old()
if [ -d $1/MPI ]; then
version=$(cat $1/MPI/version)
echo "AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA $version"
if [ x"$version" != x"5" ]; then
echo "NOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO $version"
echo -e "\033[1;34;5m -------------------------------------------------------------------------------------- \033[0m"
echo -e "\033[1;34;5m MPI has been updated to version 4.0.2, the component will be updated automatically \033[0m"
echo -e "\033[1;34;5m -------------------------------------------------------------------------------------- \033[0m"
sleep 5
exit 1
rm -rf $1/MPI/include
rm -rf $1/MPI/lib
rm -rf $1/MPI/bin
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment