Commit 759ed13d authored by incardon's avatar incardon

Forcing install mpich on centos + fixing installation of PETSC on centos

parent cea5735c
......@@ -14,10 +14,15 @@ echo "make target: $target"
echo "compilation type: $comp_type"
echo "Branch name: $branch"
#if [ x"$hostname" == x"cifarm-centos-node.mpi-cbg.de" ]; then
if [ x"$hostname" == x"cifarm-centos-node.mpi-cbg.de" ]; then
#we retest PETSC installation
# rm -rf $HOME/openfpm_dependencies/openfpm_pdata/$branch/PETSC
#fi
rm -rf $HOME/openfpm_dependencies/openfpm_pdata/$branch/PETSC
rm -rf $HOME/openfpm_dependencies/openfpm_pdata/$branch/MPI
rm -rf $HOME/openfpm_dependencies/openfpm_pdata/$branch/PARMETIS
rm -rf $HOME/openfpm_dependencies/openfpm_pdata/$branch/HDF5
install_MPI_mpich.sh $HOME/openfpm_dependencies/openfpm_pdata/$branch/ 4
fi
if [ x"$hostname" == x"cifarm-mac-node.mpi-cbg.de" ]; then
export PATH="/usr/local/bin:$PATH"
......
#!/bin/bash
# check if the directory $1/MPI exist
if [ -d "$1/MPI" ]; then
echo "MPI already installed"
exit 0
fi
rm -rf mpich-3.3
rm mpich-3.3.tar.gz
wget http://ppmcore.mpi-cbg.de/upload/mpich-3.3.tar.gz
tar -xvf mpich-3.3.tar.gz
cd mpich-3.3
#
# --disable-mca-dso \
# --disable-sysv-shmem \
# --enable-cxx-exceptions \
# --with-threads=posix \
# --without-cs-fs \
# --with-mpi-param_check=always \
# --enable-contrib-no-build=vt,libompitrace \
#
#--enable-mca-no-build=paffinity,installdirs-windows,timer-windows,shmem-sysv
#
#
if [ x"$6" == x"1" ]; then
echo "Installing MPI with GPU support"
./configure --prefix=$1/MPI --enable-fortran CC=$3 CXX=$4 F77=$5 FC=$5
else
echo "Installing MPI without GPU support"
./configure --prefix=$1/MPI --enable-fortran CC=$3 CXX=$4 F77=$5 FC=$5
fi
make -j $2
make install
# Mark the installation
echo 4 > $1/MPI/version
......@@ -6,11 +6,11 @@ if [ -d "$1/MPI" ]; then
echo "MPI already installed"
exit 0
fi
rm -rf openmpi-3.1.3
rm openmpi-3.1.3.tar.gz
wget http://ppmcore.mpi-cbg.de/upload/openmpi-3.1.3.tar.gz
tar -xvf openmpi-3.1.3.tar.gz
cd openmpi-3.1.3
rm -rf mpich-3.3
rm mpich-3.3.tar.gz
wget http://ppmcore.mpi-cbg.de/upload/mpich-3.3.tar.gz
tar -xvf mpich-3.3.tar.gz
cd mpich-3.3
#
# --disable-mca-dso \
......
......@@ -19,7 +19,9 @@ source script/solve_python
discover_os
function test_configure_options() {
cd petsc-3.10.2
$python_command ./configure COPTFLAGS="-O3 -g" CXXOPTFLAGS="-O3 -g" FOPTFLAGS="-O3 -g" $ldflags_petsc --with-cxx-dialect=C++11 $petsc_openmp --with-mpi-dir=$mpi_dir $configure_options2 --with-debugging=0
cd ..
}
function haveProg() {
......@@ -44,6 +46,16 @@ else
ldflags_petsc=
fi
#### Download and uncompress petsc
rm petsc-lite-3.10.2.tar.gz
rm -rf petsc-3.10.2
wget http://ppmcore.mpi-cbg.de/upload/petsc-lite-3.10.2.tar.gz
if [ $? -ne 0 ]; then
echo -e "\033[91;5;1m FAILED! Installation requires an Internet connection \033[0m"
exit 1
fi
tar -xf petsc-lite-3.10.2.tar.gz
####
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment